0

I'm doing a child theme just to patch a bug in the parent one. It's the first time I do this.

I have :

  • style.css <- mandatory file to load the parent style
  • functions.php <-- mandatory file
  • screenshot.png <-- the image load correctly
  • content-foo.php <-- it used correctly

My problem is when I activated the child theme every admin options in the theme customizer do not bind anymore. Even if I save the backgound image or logo or any color again, the site and the preview do not recognize it.

I know I do not need to override header.php, index.php... : answer here

style.css

/*   
Theme Name: Foo Patches
Theme URI: https://... 
Description: To fix Foo theme.
Author: <a href="https://...">John Doe</a>
Author URI: https://...
Version: 1.0
License: Comercial
License URI: http://...
Tags: left-sidebar, right-sidebar, custom-background, custom-header, custom-menu, editor-style, full-width-template, theme-options, translation-ready
Text Domain: Foo Child
Template: foo
*/

/* You can start adding your own styles here. Use !important to overwrite styles if needed. */

functions.php

add_action( 'wp_enqueue_scripts', 'foo_patches_enqueue_styles' );
function foo_patches_enqueue_styles() {
     wp_enqueue_style( 'foo_style', get_template_directory_uri() .  '/style.css' );

}

So what happen ? Someone has got an idea ?

  • guess you are missing the functions.php codex.wordpress.org/Child_Themes – Lucky Chingi Feb 20 '18 at 17:08
  • Ok but what I need to do in functions.php because I need just the same options and normally it should load the parent's one, no ? – J.BizMai Feb 20 '18 at 17:16
  • The links tells you the basic code you need in functions.php – Lucky Chingi Feb 20 '18 at 17:19
  • I put an error_log in the parent's functions.php and it's loaded – J.BizMai Feb 20 '18 at 17:19
  • I would like to avoid to copy unusefull code. – J.BizMai Feb 20 '18 at 17:20
0

The problem was because the parent PAID template does not work with the customizer page and use a submenu page to load options. Because just a bad user experience, I lost my time.enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.