0

I made a fresh installation of the newest version of the WordPress in Ubuntu Server 14.04 where the PHP version is PHP 5.5.9-1ubuntu4.22 (cli) (built: Aug 4 2017 19:40:28)

I managed to install the WordPress site and a purchased theme successfully till now.

Will I encounter any problem with the site development?

I am asking because later I noticed this in WordPress requirements..

PHP version 7.2 or greater

  • It is written there: not required, but recommended. And below you can see that WordPress can work with PHP 5.2.4+ – KAGG Design Feb 19 '18 at 8:24
  • PHP 5.5 is end-of-life and may leave you exposed to unpatched security vulnerabilities. Upgrade or change host. Not being able to use a newer version is worth changing host over. – Jacob Peattie Feb 19 '18 at 11:42
1

No, you will not face any problem because of PHP 5.5. WordPress recommends (not required or mandatory) PHP 7.2 because it has better performance than the older versions. If you need better performance than PHP 5.5 then you should definitely use PHP 7.2. Btw, WordPress even smoothly works with PHP 5.2.4!.

  • Vastly more important that performance improvements is that PHP 5.5 is end-of-life, and may leave you exposed to unpatched security vulnerabilities. – Jacob Peattie Feb 19 '18 at 11:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.