1

I am developing my first WordPress Theme and I would like to add a Customization Menu, initially to change Social Networks Link addresses... I have added following to my functions.php:

/**
 * Add Theme Customize Options
 */
function www_perlur_cloud_customize_register($wp_customize) {
  /**
   * Add Social Networks Links section to WordPress Theme Customize Menu
   */
  $wp_customize->add_section( 'www_perlur_cloud_social_networks_links',
    array(
      'title'         => __('Social Networks Links','www_perlur_cloud'),
      'priority'      => 30,
      'capability'    => 'edit_theme_options',
      'description'   => __('Allows you to customize Social Networks Links for PERLUR Group theme.','www_perlur_cloud')
    )
  );
}

/**
 * Activate defined functions.
 *
 */
add_action('init', 'disable_emojis');
add_action('customize_register', 'www_perlur_cloud_customize_register');

But when I click Customize in the Theme section of WordPress Administration I do not see the section "Social Network Links". Any idea how it may be, and what I have to do to fix it?

Update 1:

I have added following code into www_perlur_cloud_customize_register function:

  $wp_customize->add_control('social_icons_color',
    array(
      'type' => 'color',
      'priority' => 10, // Within the section.
      'section' => 'www_perlur_cloud_social_networks', // Required, core or custom.
      'label' => __('Date'),
      'description' => __('This is a date control with a red border.'),
      'input_attrs' => array(
        'class' => 'my-custom-class-for-js',
        'style' => 'border: 1px solid #900',
        'placeholder' => __('mm/dd/yyyy'),
      ),
    'active_callback' => 'is_front_page',
    )
  );

and no change... I have even tried to use "Additional CSS" where I added simply /** */ and clicked Publish. But no change... :-(

Update 2:

Could the problem be that the theme directory is www.perlur.cloud and not www_perlur_cloud?

  • Have you tried adding setting to your section? – sandrodz Feb 13 '18 at 20:47
3

You won't see the section as there is no control that belongs to that section. In other words, that's a blank section. And customizer doesn't show any blank section, you need at least one control under that section. It's a usual behavior, so no worries.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.