Ubuntu Server, LAMP stack, freshly self-installed WordPress.

Apparently I can't use direct filesystem access method because files are owned by different owners (WP core unpacked by me and files WP creates by www-data).

I tried my credentials for ftp method, but either something goes wrong or there is simply no FTP server installed in stack.

Googled up suggestion to install libssh2-php and use ssh method. Filling my credentials (except keys, no idea what to put there) it worked for deleting plugins, but fails to install new ones with following error:

Downloading install package from http://downloads.wordpress.org/plugin/serverbuddy-by-pluginbuddy.0.1.6.zip…

Unpacking the package…

Could not copy file. /var/www/wp-content/upgrade/serverbuddy-by-pluginbuddy.tmp/

I am little lost which method to poke. Should I try to tweak and enforce direct? Or how to fix ssh? Or just install some ftp server?


Ideally, you install php-suexec, so that the php script runs as the file's owner. This allows the direct method to be used without requiring any permission changes.

  • I installed the apache2-suexec package but it didn't work out of the box and I got lost at googling settings. Anyway for my VM I solved issue with ssh by setting up password for root and using those credentials. Accepting this answer because it's more proper and how it should be done in production. – Rarst Oct 17 '10 at 14:59

How about ...

apt-get install proftpd

I mean, suexec + root as the owner of the scripts ... could lead to undesired results.

I've documented some relevant settings on my blog: proFTPd configuration

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.