0

My site would display the message This connection is not private when I visited the https version. Trying to fix this I went to the Wordpress admin panel and to Settings and added a "s" to the two URL fields there as suggested here.

Once I did that all pages including wp-admin display the 404 Page not found error. I was trying to see if I can reverse this via Filezilla but I am not sure what file to look at.

How can I fix the 404 error?

Update: I was able to remove the 's' from 'https' n cPanel - Databases - phpMyAdmin. There I clicked on my database and then on the wp_options table. Clicking on edit for the rows with option_value siteurl and home lets you edit the option_value field where you can remove the 's'.

  • 1
    Did you install SSL certificate for your domain? You should be able to acquire a free one using letsecrypt service. Check with your hosting provider. – Z. Zlatev Feb 8 '18 at 12:08
  • @Zlatev I am on hostgator and I haven't installed any SSL certificate. I thought hostgator implemented that by default. – multigoodverse Feb 8 '18 at 12:26
  • 1
    no, unfortunately it doesn't work like that. Most decent hosting providers already integrated with "let's encrypt" but still require you to manually enable that integration. – Z. Zlatev Feb 8 '18 at 14:02
  • Hostgator does not support let's encrypt. If you want SSL you'll need to pay for it, or consider another provider. – Iceable Feb 9 '18 at 6:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.