2

My site has been updated automatically to Wordpress 4.9.3. After that, there is one error message in error log :

PHP Fatal error: Call to undefined function request_filesystem_credentials() in ../wp-admin/includes/class-wp-upgrader-skin.php on line 93

How can I resolve this message?

Thank you.

  • 2
    Can you update to 4.9.4? Alternatively try downloading the WordPress files from the official source and uploading them again via FTP – kero Feb 7 '18 at 13:26
  • The official WP news has information about this, upgrade manually to 4.9.4 – Tom J Nowell Feb 7 '18 at 13:44
7

Upgrade manually to 4.9.4, it's a known issue with 4.9.3

  • 1
    See Release Post on Make and the Technical Overview of what happened for more information. – Howdy_McGee Feb 7 '18 at 16:18
  • I have an extremely tweaked wordpress instance running live, and as legends said, doing this is the biggest mistake, but now I am being new to team. I do not have option to suggest a new scratch project... now in this case, how can I resolve this error without upgrading the wordpress version to the suggested one – OM The Eternity Mar 22 '18 at 5:09
  • 1
    Upgrading manually will do the same things as the auto-updater, if you've modified WP Core itself then you'll need to do the process by hand, there's no way around it, it's unavoidable. You can replace core mods with proper built functionality piece by piece, using filters etc. Keep in mind too that by modifying core the security of core is compromised, you could face serious issues going forward, especially if there's a data breach – Tom J Nowell Mar 22 '18 at 13:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.