0

WordPress 4.9.2

On the backend, the Page/Post editor seems to be loading twice. First it displays the Text version of the page/post. Then just when you think it finished, it reloads again with the Visual version.

My preference is Text as I speak HTML fluently, but I understand most users don't. Making this a user preference would be better than this double loading. This is really slowing down productivity.

Is anyone else observing this behaviour?

0

No, this is not a normal behavior. Try to set default editor, and that should fix it. If it does not fix the problem, you may have one of your plugins causing it. Deactivate all plugins, and then reactivate them, one by one, until you find one, which is responsible. Code below goes to functions.php:

Set default editor to HTML:

add_filter('wp_default_editor', create_function('', 'return "html";'));

Set default editor to Visual:

add_filter('wp_default_editor', create_function('', 'return "tinymce";'));

Update: the proper use of a closure, will be:

add_filter('wp_default_editor', function() { return 'tinymce'; } );
  • 1
    Note that create_function() has been deprecated in PHP 7.2. One should simply use function() { return 'html'; } instead. – swissspidy Feb 2 '18 at 20:49
  • Yes, you are right. I'll update my answer. – Frank P. Walentynowicz Feb 2 '18 at 21:02
  • Setting the default editor is not a solution as I am only the webmaster and the clients likely have their own preferences. I guess checking which of their 30 plugins is the cause is the next step. To narrow it down I assume I'm looking for a plugin that interacts with the post/page editor? – Codedogs Feb 15 '18 at 23:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.