0

I've been developing a WP Multisite on a temp URL for some time now. The site is ready, so I changed my settings around, did a find and replace in SQL from the temp domain to the permanent domain, pointed my domain over.....

and now I get a "Can't Select Database" error.

I think part of the problem is my DB user is no longer being allowed to access the database anymore. When I went back into cPanel, I tried to connect my DB user to the database and this error came up.

The system received an error from the “MySQL” database “mysql”: ER_NONEXISTING_GRANT (There is no such grant defined for user 'stack_db16' on host 'res154.servconfig.com')

Of course, mysql is not the actual DB name. It's something else.

So what is going on here? Totally confused and frustrated by this.

bumped to the homepage by Community yesterday

This question has answers that may be good or bad; the system has marked it active so that they can be reviewed.

0

Solved it! Problem was I needed to update the wp_blogs table with the proper domain and path.

0

That's a standard error if WordPress cannot connect to the database. Did you update the database details in the wp-config.php file?

I recommend double checking the DB_NAME, DB_USER, DB_PASSWORD, and DB_HOST values.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.