0

I am testing my new WP site. I wanted to see how it worked using a text-only browser, so I fired up "links" from my shell to visit the site. At the top of the page before my navigation menu, the following links were visible:

<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="canonical" href="https://www.citizensonline.org.uk/" /> (Yoast)
<link rel='https://api.w.org/' href='https://www.citizensonline.org.uk/wp-json/' />
<link rel='shortlink' href='https://wp.me/P9c2Zs-1l' />

(Only the words profile, canonical, https://api.w.org/ and shortlink are actually visible, but they are hyperlinked).

These lines are from the <head> section of the source code, so why are they showing up on the page - surely the page should only render content from within the <body>, and these header links should be inaccessible to the browser UI? This seems like a bug to me. And presumably one from Wordpress, as this is the only engine that is generating the HTML content.

Maybe this is a bug with the "links" browser rather than a Wordpress bug but I can't find any other reference to this anywhere online. The links are not visible when using a standard browser like Chrome etc.

Other kinds of tag from the head section are not rendered, e.g.:

 - <link href
 - <link rel="pingback"
 - <link rel="alternate"
 - <link rel='stylesheet'
 - <link rel='dns-prefetch'
 - <link rel="icon"
 - <link rel="EditURI"
 - <link rel="wlwmanifest"
 - <meta
 - <script

... none of these kinds of tag is visible so why would the other 4 be?

I hope somebody can shed some light on this for me. Thank you!

closed as off-topic by Nathan Johnson, EAMann Feb 16 '18 at 0:01

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Something is adding broken HTML to your head somewhere, causing this to happen. Look at the raw HTML of the page (by going to Resources/Sources tab of the inspector) and see if there's any broken tags or similar. Or post the full contents of <head> so people here could see. – Jacob Peattie Jan 24 '18 at 14:39
  • Thanks Jacob. I can't see any obvious problems, though there is a lot of stuff in the head. I've pasted it here (though it's obv available through view:source anyway) pastebin.com/6RCrh8pk – Francis Barton Jan 24 '18 at 14:47
1

Looks like your missing the / before the close on profile Try this

<link rel="profile" href="https://gmpg.org/xfn/11"/>
  • Thanks Jeremiah - well spotted! Hard to believe I had missed that myself. Anyway, I've fixed it but the links are still showing when viewed in a text-only browser. – Francis Barton Feb 12 '18 at 12:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.