Have a look, please: http://www.heavyweightsoftware.com/blog and click on Blog. You should see my article, How to Use Tabs with Angular 5. Now click on this article to view it and you should get an "Oops! Can't find that." page.

What's up with that?

It looks like something odd is going on with single quotes in the link, but what's putting them there?

  • There's a single quote at the end of your permalink. Could be due to a problem in the theme, could be something weird with rewrite rules... hard to tell without further information.
    – WebElaine
    Jan 22, 2018 at 15:09
  • Even if you type in the right URL a quote appears in the middle, so it's some rewrite setting somewhere. The answer of saving the permalinks is a great first step tot ry.
    – WebElaine
    Jan 22, 2018 at 15:25

3 Answers 3


Have you tried to save the permalinks again?

Step 1: In the main menu find "Settings > Permalinks".
Step 2: Scroll down if needed and click "Save Changes".
Step 3: Rewrite rules and permalinks are flushed.
  • Just realised your post permalink is heavyweightsoftware.com/blog/'/2018/01/22/…' there's some extra ' in there... Jan 22, 2018 at 15:24
  • Tried this, but no dice.
    – Thom
    Jan 22, 2018 at 15:41
  • Can't help without more information :) Try updating your question with more details, code etc. Jan 22, 2018 at 15:47
  • I don't know what else to add. I only write posts here. I created a post. It invented the link for it. I published the post and can't navigate to the link. I think this is a pretty vanilla wordpress install. I haven't installed any plugins.
    – Thom
    Jan 22, 2018 at 15:49

Based on Catia's feedback, I went back into Settings > Permalinks and found that I had a custom structure selected that contained the single quotes. Most likely this came from the provider as I can't imagine why I would have done that.

At any rate, I changed the permalink setting to one of the pre-defined ones, Post Name, and saved it, which regenerated the permalinks and now everything is working properly.


This may be due to your web server. If you are a linux user, you can follow these simple steps:

sudo nano /etc/apache2/apache2.conf


<Directory /var/www/>

And make sure the AllowOverride directive is set to All.

This worked for me. I hope it works for you as well. Good luck!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.