0

I just setup up a new WordPress site at http://www.heavyweightsoftware.com/blog. When navigating to the site I'm redirected from http to https. This throws a warning since I don't have a SSL certificate installed on this domain.

How do I prevent WordPress from redirecting my site and resolving to http?

closed as off-topic by Krzysiek Dróżdż, Jacob Peattie, cjbj, Brooke., Ethan Jinks O'Sullivan May 16 '18 at 15:21

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    Is your siteurl and home set to http or https? (in Settings -> General) And are you sure, there isn't a redirect setup by your host? – kero Jan 22 '18 at 13:56
  • 1
    @kero That did it, thanks! Wonder why I did that? Please post as answer so I can give you credit. – Thom Jan 22 '18 at 14:00
  • 2
    Possible duplicate of Stop WordPress from using HTTPS and just use HTTP – TAHA SULTAN TEMURI May 6 '18 at 8:46
1

If your site and home URL are set to https, WordPress will redirect all requests made to it.

Please check under Settings -> General if this is the case.

1

Will you please follow one of these steps to fixed out.

  1. Make sure the site configured correctly, in the wp_options table double check on siteurl and home value.

  2. Also, you can check for .htaccess file to figure out any problem in Rewrite rules which cause redirecting issues.

More information can be found here

Not the answer you're looking for? Browse other questions tagged or ask your own question.