Thanks in advance for any useful tips. I'll cut to the chase.

I followed these guides to set up my wordpress server:
1 - https://www.techcoil.com/blog/setting-up-wordpress-on-raspberry-pi-3-with-raspbian-stretch-lite-nginx-mariadb-and-php-7-as-the-lemp-stack/
2 - https://www.stewright.me/2014/06/tutorial-install-wordpress-on-a-raspberry-pi-using-nginx/ (referred the section titled "Set some permissions" only, otherwise all done with first tutorial)

Uploading media still didn't work, so I performed the following in the www folder to try and cover all bases:

sudo chmod -R 777 .

Yet still, when I try to upload media in Wordpress, it says:
HTTP error"

What am I missing? About me: Not an expert in this stuff clearly, but can get the concepts pretty quickly with some explanation. Thank you!!

  • Forgot to mention, running Raspi 3 + Raspbian Stretch, and using my own IP address through NoIP as my "DNS service". Site runs fine with a new WP install, blog posts, etc. Just can't upload media/plugins from my laptop in the wp interface.
    – Sean
    Commented Jan 21, 2018 at 5:01
  • Oh god, it was because the file was too big, even though it was less than the 2MB size limit stated in WP. I tried a 1.4MB file that wasn't working work, but a 400KB file worked. Thanks for the help
    – Sean
    Commented Jan 26, 2018 at 20:34

1 Answer 1


you need to change the owner of the wordpress folder to www-data.

For example, if you put your wordpress folder in /var/www/my_new_wordpress_site, you will need to run the following command:

sudo chown -R www-data:www-data /var/www/my_new_wordpress_site

  • No luck :( Still says HTTP error. Tried it in the parent folder as well and did a reboot to be sure.
    – Sean
    Commented Jan 26, 2018 at 17:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.