0

First of all the technical details:

  • OrangePi Zero (512Mb)
  • Debian for Orange Pi
  • Apache2
  • PHP5
  • MYSQL
  • Wordpress

I have at home an OrangePi and I installed a WordPress on it. I registered a DNS name (exlample.ddns.net) on noip.com.

I used the following guide to the installation:

After the installation, the blog site is at home reachable and manageable, but from outside can't reachable (It try reach my private address): So I modified the site & home URL in WordPress settings. After that I can reach the site from outside with the DNS name properly, but I cannot reach the blog site from home (only from outside).

Do you have any idea on this issue?

  • What hostname did you set up in apache? What was the settings in site & homeurl, and what did you change it to? – janh Jan 20 '18 at 12:52
  • the site and home url were: private ip – tocsikbt Jan 20 '18 at 17:31
  • now: example.ddns.net in apache I didn't modified any settings. – tocsikbt Jan 20 '18 at 17:33
  • How about adding example.ddns.net to your hosts file with the private IP? – janh Jan 20 '18 at 17:48
  • It's done, but the situation is constant :/ – tocsikbt Jan 20 '18 at 17:55
0

The problem has been resolved. I added the DNS name and the IP-Address of the Server to the host file of my PC. So I can reach my website from the outside and from my private LAN also.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.