0

I migrated my wordpress site to my live site. As mentioned in the title my site will look bad if I visit it and I am ot logged in cPanel. Guess it means resources are not accessable to all users. How to make site resources accessable to all?

  • what do you mean by "looks bad", do you have any errors in your logs? did you check with a debugger (ie f12) to see if something is missing? There could be LOTS of things wrong here... – rudtek Jan 8 '18 at 17:15
  • Try opening opening the Developer Tools in your browser (like in Chrome). In the "Console" tab it should provide more details regarding which resources are not loading. – Scruffy Paws Jan 8 '18 at 17:39
  • @rudtek I mean that things like the logo, the fonts, and scripts won't load, unless I am logged into the cpanel, therefore the root of the error must be on the accessibility to the resource urls, which are not accessible to anonymous (non-logged) users at this point... – Giorgio Vitanza Jan 8 '18 at 20:43
  • do you have ssh access? – rudtek Jan 8 '18 at 21:01
  • @rudtek Nope I don't, do I need it? – Giorgio Vitanza Jan 8 '18 at 21:33
1

Looks like some of your assets are using http://localhost/... links instead of your domain which is why they aren't loading. These might be hardcoded in your theme or you may want to check your options table in the database for option_name "siteurl" and "home" and make sure they are updated to use the right URL instead of http://localhost

  • It's also a good idea to use a database migration or site migration plugin when you move from localhost to a live site. They handle a lot of search-and-replace cases that manually changing won't. – WebElaine Jan 9 '18 at 17:06
  • Yup I had home set as localhost still, and I also recommend step seven o this guide for anyone with this error wpbeginner.com/wp-tutorials/…. – Giorgio Vitanza Jan 9 '18 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.