-1

EDIT: [SOLVED] Page was cached on server, I went to c-panel and purged cach for domain and now it works fine.

I've been banging my head with this one for hours, so any help is welcome.

I have a new wordpress install. I've added a theme Illdy and I've imported dummy content via Illdy Companion. After some time working on the theme, I've noticed that while logged out homepage doesn't show any changes but displays dummy content.

So I deleted all plugins and theme and went back to twenty seventeen, but it still displayed dummy content on homepage, in plain html since the theme was removed. Then I reinstalled whole wordpress, found a new theme and it now displays twenty seventeen on homepage while logged out.

In short all changes to the website are visible while logged in, and when I logout it shows homepage from different source.

If you go to website homepage you will see twenty seventeen, and if you go to any other page you will see another theme Sydney.

There are no plugins for caching.

  • could be a browser cache issue – inarilo Jan 5 '18 at 18:04
  • The issue is same on different browsers and computers. Tried Ctrl+F5 in chrome, doesn't work. Also tried clearing browsing history, cookies, site data, image and files in chrome, still the problem is same. – bajaist Jan 5 '18 at 18:11
  • Check with your host, too. They might be caching or using a CDN or something. – Pat J Jan 5 '18 at 19:25
  • 1
    It was cached on server, I went to c-panel and purged cach for domain and now it works fine. Thanks – bajaist Jan 5 '18 at 20:01
0

Not enough reputation to comment, have you checked the home page settings in the admin?

under settings->reading there is an option to set the homepage.

per comments discussion was server caching

  • Yes. Changing betweeen static page and latest posts does affect homepage while logged in. But has no effect while logged out, it still displays page from twenty seventeen. – bajaist Jan 5 '18 at 19:22
  • your header shows a x-proxy-cache HIT response, you could be serving up the page from the server's cache, not the browser cache. I didn't see cloudflare or one of the DNS options, but that can also cause caching issues. Try flushing the nginx cache and see if that helps. – 1Bladesforhire Jan 5 '18 at 19:31
  • It also looks like you need to change the front page in the settings for the theme itself under general illdy support – 1Bladesforhire Jan 5 '18 at 19:43
  • 2
    It was cached on server, I went to c-panel and purged cach for domain and now it works fine. Thanks alot for your help, I wouldn't be able to fix it without you. I've deleted Illdy few hours ago. – bajaist Jan 5 '18 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.