0

I am using WP 4.9.1 and have two wordpress installs on subdomains within the same root domain. I want our users, who have profiles on one of the installs to be automatically logged into the other install when they log into the first one.

I have followed the instructions on this thread Single sign on between two wordpress website

Then I followed the additional instructions on this thread How Access Multiple Wordpress sites with a single login

I feel like I am very close to getting this working properly, but what is happening now is: when I attempt to log into either install, it just refreshes the login page and doesn't go anywhere. There are no error messages displayed anywhere, including inspect console.

I am thinking I must be missing one step somewhere. Can anyone help? If possible, I would be willing to share the files I have customized in email so someone can review them for mistakes.

Any help will be appreciated.
Thank you

  • Are all the sites either HTTPS or HTTP? If they're not all the same, that can give you problems. Also make sure to use a fresh new Incognito window so you're not cached. Finally, another thing that can cause problems between servers is if they don't use the same port. In my own case, we do single sign-on with an outside service - there are plugins that will allow users to sign in with their Gmail or Active Directory login, for example. – WebElaine Jan 5 '18 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.