0

Last week I came across "HTTP 500 error" on my website and i managed to solve it by deleting all folders in theme directory and then reinstalling theme from admin panel.

Today I faced same issue. I don't think there is any problem with theme. Although by deleting theme folders i could solve problem.

My config: VPS Hosting: Ubuntu, Nginx, WP(latest); RAM: 1GB; CPU: 1; Storage: SSD; Theme: Ribon Lite; SSL: Cloudflare Free flexible SSL;

Today I increased memory limit to 500MB by editing wp-config.php. Is it possible problem maybe with memory limit. What can i do so i dont get into same problem again.

  • One way is to check the Nginx access and error logs, that will give you an idea of what's wrong if it's not related memory resource handling. – bravokeyl Dec 31 '17 at 13:23
  • enable config by changing define('WP_DEBUG', false); to define('WP_DEBUG', true); in wp-config.php then you can see the error. – Akshat Dec 31 '17 at 14:03
  • WordPress debug file is located at /wp-content/debug.log. Within this file you search for the latest fatal error. Whether it's a memory cap issue or not will be visible within the debug.log file. – Bas van Dijk Dec 31 '17 at 14:59
  • @BasvanDijk After define('WP_DEBUG', true); there is no debug.log file inside the wp-content/, what i need to do, how can i find the error? – Gem Jun 20 at 10:13
  • @Gem define( 'WP_DEBUG', true ); does not trigger the actual logging of the errors. You should also use define( 'WP_DEBUG_LOG', true ); – Bas van Dijk Jun 20 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.