i have to install wordpress 3.2.1 on IIS 5.0 (yeah, i know...) here. Brand new default wordpress installation, no plugins ore previous versions installed. So, i downloaded the 3.2.1.zip and the 3.2.1-IIS.zip, unzipped everything and set up the database, but i get the same issue every time:

everything works, except when i try to login to the admin area it keeps redirecting me back to wp-login.php?redirect_to=http%3A%2F%2Fmydomain.com%2Fwp-admin%2F&reauth=1 without any error message.


  1. all requests to http://www.mydomain.com are rewritten to http://mydomain.com
  2. tbl wp_options has siteurl and home set to http://mydomain.com
  3. i can see 2 cookies: wordpress_test_cookie=WP+Cookie+check and PHPSESSID=617cdf1966c78a56e2dd901942d41124 in my browser
  4. there is an empty file sess_617cdf1966c78a56e2dd901942d41124 in my session folder

It looks like a session problem to me. I have a cookie set in my browser, and there is a corresponding session file in my webservers session folder, but it's always empty (0 Bytes).

when i create a simple test script in the same folder as my wp-installation and manually add

$_SESSION['foo'] = 'bar';

then i can also see those values in my session files.

For the last 2 days i tried to figure out whats wrong here. The installed php files and my database are both ok, it works as it should when i moved the installation to a diffent xampp webserver on a different box. Crosschecked my php.ini and the session handling is the same as on xampp.

I pretty much tried out any suggestion i found on wordpress.org and other forums for this topic; but nothings seem to work.

  • As far as I was aware WP doesn't use sessions... I did a search for session_start( in WP core files and there isn't a single occurrence. Are you sure sessions are your issue?
    – Scott
    Commented Sep 23, 2011 at 8:18
  • Like Brady mentioned WordPress does not use Session. If you are having trouble login in you might want to clear your browser cache/cookies for the site and try again. Commented Sep 23, 2011 at 9:13
  • Yeah i tried that, but clearing cache and cookies didn't help; and i tried it in Chrome, FF and Opera. If it dosn't uses $_SESSION, where does it store my login info then? Cookies...? Commented Sep 25, 2011 at 22:23
  • Are you forced to use IIS 5.0? What is 3.2.1-IIS.zip? Is it a hacked version of 3.2.1? Have you checked your PHP error logs? Also, what are the permissions on your PHP installation? Commented Sep 28, 2011 at 13:45
  • Have you tried logging in on different browsers (specifically IE). Also, have you checked your IIS log file for 401.x errors? Commented Sep 28, 2011 at 13:54

1 Answer 1


Check out your php.ini config file and try changing the permissions for your upload_tmp_dir & session.save_path directories.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.