1

I have around 40 Wordpress sites on a Centos 6.9 Apache2.4 dedicated server and I recently upgraded it to EasyApache 4 and then in WHM multiphp_manager/config I changed all the sites to PHP7. I ran some tests after and all seemed ok but since then both myself and other team members (who are in different locations and countries) have been getting the following problems:

  1. Sometimes unable to publish a new post, as soon as the publish button is hit a 404 page returns. The post is saved in drafts but only with its title and no content. This happens on and off, some sites seem fine though.

  2. Cannot insert images into posts, uploading them seems to be fine but when trying to insert them this error can be seen in Chrome dev console:

    POST http://www.example.com /wp-admin/admin-ajax.php 404 (Not Found)

    however if I go to the above admin-ajax.php error I get a '0' in my browser.

  3. Sometimes the sites will load without any css and in the dev console there will be errors like this:

    load-scripts.php?c=0&load[]=jquery-core,jquery-migrate,utils&ver=4.9:4 POST http://www.example.com/wp-admin/admin-ajax.php net::ERR_CONNECTION_RESET

    or this:

    XHR failed loading: POST http://www.example.com/wp-admin/admin-ajax.php.

I often have to do a hard refresh to get the css to load and I have tried deactivating all plugins and activating the basic Genesis theme on some of the sites but this doesn't seem to change anything.

Im not seeing any problems on the server itself too.

I have not made any changes to the php.ini files and from what I can see in Multiphp ini editor in WHM none of the settings there should be causing this.

I also installed mod_pagespeed the other day but havent configured it yet, I am seeing a lot of errors like this in /var/log/apache2/error_log

[Wed Dec 20 21:38:49.755413 2017] [pagespeed:error] [pid 28592:tid 140159257401088] 
[mod_pagespeed 1.11.33.4-0 @28592] Failed to make directory /var/mod_pagespeed/cache/rname: 
Permission denied
[Wed Dec 20 21:38:49.755434 2017] [pagespeed:error] [pid 28592:tid 140159257401088] 
[mod_pagespeed 1.11.33.4-0 @28592] Could not create directories for file

Not sure if that's related but thought I should mention it anyway.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.