0

What else should be done if I went to my sites dir in Linux and ran this command:

sudo wp search-replace 'http://' 'https://' --all-tables && wp cache flush

and still, some images are loaded as http and not https.

?

  • What else have you done to the site? Images hardcoded in themes and plugins wont be affected by this, and you need to have set your site URLs to use HTTPs too so generated URLs work, please detail what steps you've taken. Also keep in mind you're running WP CLI as a root user, WP CLI doesn't like running as root and usually requires additional flags – Tom J Nowell Dec 11 '17 at 23:52
0

In this site I use Elementor. I solved it by going to WP-admin > Elementor > Tools > Change address, and there I've changed all http:// to https:// as well.

Then the problem solved.

I admit I have no idea why the WPCLI search and replace operation didn't cover Elementor tables as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.