1

I have use plugin Really simple SSL to enable my site to https. Everything is ok but when wordpress update my site automatically to 4.8.4. Only my homepage do not work for https otherwise another pages are ok. You can see some example in this image:

My homepage when loading: enter image description here

My homepage when full load: enter image description here

Another page is ok: enter image description here

Inaddition infomation:

My homepage: https://winecellar.vn

Another page: https://winecellar.vn/ruou-cao-cap/ruou-chi-le

Wordpress version: 4.8.4

Thank you in advance

1

Your home is working on SSL but some elements might not be loaded from https but http like third party images or scripts. Look in source of your home site generated by browser and search for http: phrase to find which elements you should fix.

| improve this answer | |
  • That's very kind of you. Thanks for your advice. Let me check and try to fix it – mrleezoo Dec 11 '17 at 8:42
0

You may please use this query on your database to change url from http:// to https://

UPDATE wp_options SET option_value = REPLACE(option_value, 'http://winecellar.vn/', 'https://winecellar.vn/');
UPDATE wp_postmeta SET meta_value =  REPLACE(option_value, 'http://winecellar.vn/', 'https://winecellar.vn/');
UPDATE wp_posts SET post_content =  REPLACE(option_value, 'http://winecellar.vn/', 'https://winecellar.vn/');
UPDATE wp_posts SET post_excerpt =  REPLACE(option_value, 'http://winecellar.vn/', 'https://winecellar.vn/');
UPDATE wp_posts SET guid =  REPLACE(option_value, 'http://winecellar.vn/', 'https://winecellar.vn/');
| improve this answer | |
  • If you found the solution I would request you to please accept it ans right answer – user132643 Dec 11 '17 at 6:46
  • That's very kind of you. Let me check by hand and if it is not possible, I will try your suggest ;). Thanks for your advice. – mrleezoo Dec 11 '17 at 8:44
  • One can simply look for URL's with non https in the backend of that specific page. – made2popular May 21 at 3:50
0

Go to the page that is not loading secure. Right click on your mouse, click inspect. click console and you will find the error. Mine was my logo image was not loading secure. I simply deleted it from my page and then re-uploaded the same image. Bam! fixed. Some other possible places you can locate the error is right clicking the page and view page source. ctrl "f" and enter http in the search bar. It will let you find any other place you may have something loading not secure.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.