1

I have read this question:

I have tried the following:

ALTER database mydbname CHARACTER SET utf8 COLLATE utf8_general_ci;
ALTER table ext_hebrewText CHARACTER SET utf8 COLLATE utf8_general_ci;

My table has one column in Hebrew: enter image description here

And I have various Javascripts that format and color it to show on the screen. This is the way it is current showing: enter image description here With some other changes, I see all question marks.

My current config.php settings are:

/** Database Charset to use in creating database tables. */
define('DB_CHARSET', 'utf8');

/** The Database Collate type. Don't change this if in doubt. */
//define('DB_COLLATE', '');
define('DB_COLLATE', 'utf8_general_ci;');

What's the right combination to get them to display. Everything used to work fine. I think it broke on one of the recent WordPress auto upgrades. It's not a font issue, because I see those same characters when I inspect the HTML on Chrome debugger tool.

  • Nearly impossible to guess without hands on access to the data. Since it's not even native WP table I highly doubt WP upgrade affected it in any way. – Rarst Nov 14 '17 at 15:49
1

I'm totally shocked. After hours of trying things and testing, I finally found the "Settings" then "Readings" option below: "Encoding for pages and feeds". After changing from UTF-7 to UTF-8, everything looks good again.

enter image description here

And even stranger, after changing it to UTF-8, the option disappears from the page. According to WordPress site, this option was removed since release 3.5.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.