1

I've got a problem here. I have a wordpress site and accidentally changed the http to https and I am not sure that I could change it back. What is sure that it loged me out and when I reload the admin login page it throws an error that my connection is not private and after that I got a 403 Forbidden page.

I have access to the FTP and tried to change the wp_config file, no success. Tried adding this:

define('WP_HOME','http://example.com');
define('WP_SITEURL','http://example.com');

it only made the admin page reachable when I entered the user and pass it reloaded the login page.

I also tried to delete the .htaccess file, perhaps it is corrupted, but did not help.

Same question on stackoverflow. Please help me with this issue.

  • clear your cache and cookies – Temani Afif Oct 31 '17 at 8:01
1

I managed to enter the admin page finally! So I added these two lines to wp_admin.php: define('WP_HOME','http://example.com'); define('WP_SITEURL','http://example.com'); afterward deleted the .htaccess file, then deleted browsing history, cleared cache and cookies. After all of this I could enter the admin page.

Then I went to options/general and options/permalinks and saved the setting, it generated a .htaccess file and now it is working.

I also tried removing the two added lines from wp_admin.php after all, but I broke the page so they are going to stay for a while.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.