1

I am having issues that seem to be related to trying to change a multisite installation to use www.

The site was initially setup without the www. I added code to .htaccess to redirect all urls to www. I changed the site the 'DOMAIN_CURRENT_SITE' to www.domain.net.au. I change the siteurl & homeurl in the db for all of the sites in the network to reflect www.domain.net.au.

Everything appeared to be ok until I tried to access the Network admin menus. http://www.domain.net.au/wp-admin/network. FAIL. ERR_TOO_MANY_REDIRECTS

I then restored all of the settings back to domain.net.au. I now can access http://domain.net.au/wp-admin/network but if I try to access the network install plugin page http://domain.net.au/wp-admin/network/plugin-install I am logged out & redirected back to the login page.

http://domain.net.au/wp-login.php?redirect_to=http%3A%2F%2Fwww.domain.net.au%2Fwp-admin%2Fnetwork%2Fplugin-install.php&reauth=1

I noticed that the url above is www. even thought I have reverted to non-www settings.

Would appreciate some help with this preferably with the www working.

Thanks

redmonds

  • When you say you changed the siteurl and home in all the sites in the db, did you make sure to get the "main" site? ie, I assume you changed it in all the wp_{number}_options tables; did you make sure to change it in wp_options? – Pat J Oct 25 '17 at 15:50
  • Pat, not initially. But yes. All wp_?_options have been updated to www. When I have the site set to www i can not access any /wp-admin/network/ it kills my session. – redmonds Oct 25 '17 at 16:04
  • Pat, Not initially. But yes. When I have the site set to www i can not access any /wp-admin/network/ pages (menus) it kills my session. 'Your session has expired.Please log in to continue where you left off.' non-www, i can access all /wp-admin/network/ pages except for /plugin-install.php unless I enter the URL manually without the www. Old settings the menu still points to www.domain.net.au/wp-admin/network/plugin-install not domain.net.au/wp-admin/network/plugin-install I found more urls in the DB updating to www. did not helped. tables: wp_site wp_sitemeta Thanks – redmonds Oct 25 '17 at 16:18
  • I'd suggest seeking out a database migration plugin. WP stores URL information in many places other than just the options table. There are probably serialized references to the old version. Once you've backed up, run the migration plugin, and then either completely obliterate your browser history/cache or else use a new Incognito window to log in fresh and see whether the problems have been resolved. Browsers cache redirects so even after the problem is fixed you'll want to make sure you're seeing the current state of affairs. – WebElaine Oct 25 '17 at 18:20
  • WEbElaine, Can you suggest one? – redmonds Oct 25 '17 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.