0

Newbie here. I set my Front page to show my latest posts using Settings/Reading. However, the Front page itself doesn't show up in Pages, which is preventing me from doing some editing (using Beaver Builder plugin). Is this normal, and if not, is there a way that I get the Front page to show in my list of pages?

  • hello there just change your file name, you should change home to another any name. like welcome, main, and etc. – osman Dec 14 '18 at 4:28
  • but I would like the blog to be on the homepage and not separately, so what do I do in that case? – Nikoloz Gachechiladze Jul 29 at 15:00
0

This is normal. To display your posts, index.php is being used. It is not a regular page created by you. Some call it a virtual page. If you want all posts being displayed on a page created by you, follow these steps:

  1. prepare two pages. One for front page, and second for posts ( you can title them Home, and Blog - their names are up to you )
  2. go to Settings -> Reading -> Front page displays, and select A static page (select below). From a drop down list of pages, choose Home, from your previous step. From the second drop down list, choose Blog, from previous step
  3. Save your changes

Now Home will be your front page, and Blog will be showing all posts.

protected by Community Jul 29 at 15:57

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.