0

I have a WordPress website with two languages English/Arabic, the English URL is the home directory localhost/mysite.

the Arabic version working when adding /ar to home URL localhost/mysite/ar, everything working fine in localhost, when published the site online everything in English working fine, only the link to Arabic version is broken page could not be found any ideas, I checked the admin panel, menus, translation, everything is already there but link broken?

0

My website is working fine now, and the solutions i have found is as follows:

The Cause

Why did this happen in the first place?

This error is most likely due to the fact that you've changed your Wordpress permalink structure. The settings for your permanlink structure are found in your Admin panel, under Settings » Permalinks. Basically, it lets you choose how the URLs of your Wordpress site will look.

How to Fix the Error - Don't worry, it's super easy...and quick

Get into your website's FTP space, and look for the .htaccess file Highlight the .htaccess file in your FTP program, and open its CHMOD settings. It's probably set to 644. Change it to 666. Go back into your Wordpress site's admin section, and navigate to Settings » Permalinks. Edit the link structure to whatever you originally wanted, and then save it. You should no longer see a "grayed out" .htaccess box on this page, saying that the file is not writable. Visit any page of your site, refresh, and confirm that the error no longer occurs. Finally, as a security measure, go back to your FTP space and change your .htaccess file from 666 back to 644 (for security purposes) since you probably will never have to edit it through the Wordpress admin panel ever again.

Refernce to solution topic

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.