I moved one of my wordpress site to an AWS instance. But once I got it working, noticed that none of the notifications or contact emails were being sent through.

On researching the issue, I found that if I set the SMTP server to be an external SMTP (my AWS instance doesn't have one), it should work. I don't need membership emails sent out from my site, just the contact form.

So I tried 2 different approaches

  1. Used the Configure SMTP plugin and configured it to route all emails via an SMTP account

  2. Using Custom Contact Forms plugin, specified SMTP the settings so emails are sent using SMTP settings in PHPMailer

None of these work. I am not getting any emails. The test email from Configure SMTP works but no emails are sent from the contact forms.

Can someone please help me with what might be wrong? Is any additional configuration needed when doing this via AWS?

  • If test emails work, maybe it is problem with your contact forms, rather than email send?
    – Rarst
    Commented Sep 12, 2011 at 20:55
  • I tried another plugin as well (Contact Forms7). And in CCF, tried setting SMTP in both General Settings as well as directly in the PHP file where mail is being sent. Doesn't work. Commented Sep 13, 2011 at 5:36
  • I use Elastic Email (elasticemail.com) for sending email and there is a plug-in for it wordpress.org/extend/plugins/elasticemailv1 that might help you.
    – user9890
    Commented Oct 31, 2011 at 22:01

3 Answers 3


The plugin WP-Mail-SMTP has always worked for me. This is with the Contact Form 7 and many others as it replaces the WP Mail functions directly.


  • I got the plugin working, but I'm getting "Could not connect to SMTP host" errors. I'm using the domain/encryption/etc settings specified in the official docs (support.google.com/mail/bin/answer.py?hl=en&answer=13287) so I'm at a loss as to what's up. Commented Apr 19, 2012 at 19:02
  • Never mind. My port setting was mismatched with the encryption method I'd chosen. Apologies! Commented Apr 19, 2012 at 19:03

I had the same exact problem. I had a successful plugin installation and successful test email, but Wordpress was still attempting to send mail via /usr/bin/sendmail. I confirmed this by checking my logs (/opt/bitnami/apache2/logs/error_log).

To finally get up and running, I simply installed sendmail with the following commands:

$ sudo apt-get update
$ sudo apt-get install sendmail

Which installed sendmail in /usr/sbin, so I created a symlink to complete the installation:

$ sudo ln -s /usr/sbin/sendmail /usr/bin/sendmail

Hope that helps.


I agree with Eric, although I think postfix is even easier and won't require the symlink:

$ sudo apt-get update
$ sudo apt-get install postfix

You'll be walked through configuration options for postfix then, but on every RedHat, Debian, Ubuntu, or Amazon Linux AMI I've used in the past couple of years, the OOTB setup of Postfix works just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.