-1

I followed every step, cleared all mixed content warnings/errors but as soon as I change the home_url and site_url to https it gets stuck in an infinite loop.

if I only change the site_url it's the admin panel who get stuck in a redirect loop.

I also noticed the following redirect loops:

  1. https://example.com/blog -> https://www.example.com/blog
  2. https://www.example.com/blog -> http://www.example.com/blog/
  3. http://www.example.com/blog/ -> https://www.example.com/blog/

I can't seem to find why where it forces the trailing slash (number 2) but I think it's Wordpress doing this.

Did I forget to do something specific?

WP version: 4.7.6

Plugins:

  • BackUpWordPress
  • Bunyad Page Builder
  • Bunyad Shortcodes
  • Bunyad Widgets
  • Dynamic Featured Image
  • Facebook Open Graph, Google+ and Twitter Card Tags
  • HTTP / HTTPS Remover
  • Lazy Facebook Comments
  • Meta Box
  • Quick Featured Images
  • Redirection
  • Regenerate Thumbnails
  • Simple Follow Me Social Buttons Widget
  • Relevanssi
  • Slim Jetpack
  • Speciale Sidebars
  • WordPress Importeerder
  • WP All Export
  • WP Missed Schedule
  • WP Retina 2x
  • WP Smush
  • WP Super Cache
  • WP-PostViews
  • WPML Compatibility Test Tools
  • WPML Multilingual CMS
  • XML Sitemap & Google Nieuws feeds
  • and a custom plugin
  • Does your permalink-setting use a trailing slash? What's your server environment like? Does WP recognize that a connection is secure ($_SERVER["HTTPS"] == "on")? Is it really a loop (3 going back to start at 1?) or is it just 3 redirects that you want to shorten to one? – janh Oct 12 '17 at 7:16
0

backup the htaccess file and delete it..

clear the browser cache..

go to your database yourprefix_options table

change the siteurl and home with https://example.com/blog

i am assuming you are running wordpress on the subdirectory called blog if not the case change the url to https://example.com and open the wp admin with https link

go to settings permalink and click on save changes..

and as you have WP Smush & WP Super Cache installed do clear all the cache first to avoid any issues.

I hope it'll solve your issue

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.