0

I set up a WordPress site under a temporary domain name, using http protocol. It works fine.

Now I want to make it live under a completely different domain name, with https enabled.

My first step was to obtain an SSL certificate for the new domain name. I enabled Apache to accept https requests using the new domain name. I verified this was working by accessing the site using the new name. Of course, since the site name in WordPress general settings is the old http address, my browser was redirected there.

So I logged in to wp-admin and changed the site url fields to the new domain name (with https).

As soon as I saved the page, I was redirected to a login page (which seemed to be missing its css). But trying to login on that page just redirects back to the login page again.

I did this successfully before with another site, so I'm confused why it doesn't work this time, as I think I have been through the same steps.

  • 1
    Have you tried a database migration plugin? WP stores serialized data about the URLs so often simply updating the home and site_url option is not enough. Also try an Incognito window or another browser to see if you have old redirects cached. – WebElaine Oct 11 '17 at 20:50
  • Thanks - must have been caching, because using an incognito tab solved the problem. If you make your comment into an answer, I will accept it. – Nikki Locke Oct 11 '17 at 21:31
  • Sometimes it takes time to activate SSL – Jaed Mosharraf Oct 12 '17 at 6:10
1

Have you tried a database migration plugin? WP stores serialized data about the URLs so often simply updating the home and site_url option is not enough. Also try an Incognito window or another browser to see if you have old redirects cached.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.