0

I have a really weird issue. I use the Facebook Open Graph, Google+ and Twitter Card Tags plugin to create open graph tags for my wordpress pages. Normally this works smoothly. It takes the first image of a page and uses it as the og:image tag.

Example page: https://ungehorsam.org/programm/geschichten

The created tag (see HTML code of page linked above) looks like this:

<meta property="og:image" content="https://ungehorsam.org/wp-content/uploads/mlk_web.jpg"/>

However, I have one weird problematic page. The page does not load: https://ungehorsam.org/programm/empty-cages

I inspected the HTML code and it seems that it stops right where the facebook open graph tags should appear. It turns out, that if I remove the image from the post, the page loads normally. Also: If I use a different picture than this one, the page renders as expected. It seems that only when I use this specific picture, the open graph tags cannot be generated by the plugin.

So I tried:

  • use a different picture than this one => page loaded
  • delete and reupload the problematic picture => page still does not load
  • delete, save the picture with slightly different quality, and reupload it => page still does not load

I ran out of ideas on how to tackle this now. What is the problem with this picture? Why can't the plugin create the open graph tags if this picture is included in the post?

closed as off-topic by Mark Kaplun, Jack Johansson, cjbj, bosco, Howdy_McGee Sep 27 '17 at 20:21

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    It might be that the plugin has a problem with the word ´empty´, but you should really contact its author about this. – cjbj Sep 25 '17 at 12:31
  • I have a fix for this bug here linux.m2osw.com/… -- the problem is that the plugin loads the first 32Kb of the image and if the width/height and other info are past that threshold, then the load fails and you get a WSOD. – Alexis Wilke Dec 9 '17 at 18:43
1

Not a direct answer to your question, but possibly a resolution to your problem.

Downloading the same image from another source likely resulted in an exact copy (hash-wise) since they probably got it from the same source you did. A wild stab in the dark here, but it's possible there's something about the image data or meta-data that doesn't play nice. What you could try to resolve it is to open the image in your favourite editor and remove or change any meta-data in the image and re-save it. Even if there's none in there, re-save it anyway (possibly with a different compression setting to force a completely new file). You could even go so far as to save it as a new data-type, such as png.

If that solves it, then you can move on. If it doesn't I'd say get in touch with the plugin developers and see what they have to say about it.

  • I already did something like this as written above delete, save the picture with slightly different quality, and reupload it => page still does not load. However, I will try to modify the metadata and/or change filetype. I will report back later. – beta Sep 24 '17 at 12:25
  • ahh sorry, I missed the third point. Also, try using a different app then. Not all apps use the same algorithm to achieve the same quality levels – Madivad Sep 24 '17 at 12:31
  • removing EXIF data did the trick. the image now works. even though I do not know what exactly was the issue with the EXIF data, because it looked just fine. here is a screenshot of the EXIF data: imgur.com/a/gOjfd – beta Sep 24 '17 at 15:49
  • Glad it worked for you 👍, if you want to understand why start with a hex dump of the top of the files. I'd say it's just an unrecognised header in the original file. Maybe post screen shots or the actual hexdump and create a question under the main stack site and see if anyone can determine where the problem might be. – Madivad Sep 25 '17 at 0:27
  • That will work if the tool you use to save the image will save the image info before the image contents. With JPEG many tools will save that info near the end of the file. See my comment/link with a real fix in the question above. – Alexis Wilke Dec 9 '17 at 18:44
1

I would like to help you with this one however I require more information on how you created the post/page that fails. can you update your question to include the text code used to create the failing page or post so I can workout the problem. Another alternative is to use yoast plugin along with WPSSO Core plugin. These 2 plugins will sort all og data automatically. If you prefer to do og data manually then please post your un rendered html from the post / page in question.

Hope this helps.

  • does yoast interfere with jetpack or can they run both? i think i will try to do yoast + wpsso core and then report back if it still doesnt work – beta Sep 24 '17 at 12:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.