0

1 down vote favorite I am developing a Wordpress theme that requires testing with multiple devices over my local network. I use the localhost server XAMPP which runs apache on port 80.

When I access my PC's IP (192.168.0.16) port 80 using an iPad, it returns the apache directory of which I have two sites:

site1 wordpress The first site is a basic php site, this loads perfectly. The second site is Wordpress, and won't let me access it (see pic).

I have tried changing the setting inside Wordpress:

changing localhost to 192.168.0.16 inside the site and Wordpress address. Can anyone advise me on what I'm doing wrong?

enter image description here enter image description here

2
  • what is in the .htaccess file in the directory wordpress ?
    – mmm
    Sep 21, 2017 at 12:17
  • Your second screenshot should be trying 192.168.0.16/wordpress though, not localhost?
    – Rarst
    Sep 21, 2017 at 12:21

1 Answer 1

0

Go to Admin Panel > Settings > General and replace localhost with your ip-address for WordPress Address (URL) and Site Address (URL).

Or go to wp-config.php and add

define('WP_HOME','http://192.168.0.16');
define('WP_SITEURL','http://192.168.0.16');

And when you access to from other device you should go 192.168.0.16/directoryOfWordpress

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.