0

We bought a SLL certificate recently to change our website to work with https protocol. After this change, we realized that the tag:

<meta
property="og:image" content="https://[ ... url ...].jpg" />

is working when you load the website and open its source code. The thing is: Facebook sharing debug tool doesn't find this tag anymore. When I click on the link that shows me what is Facebook seeing (HTML), this tag is written like this:

<metaproperty content="https://[ ... url ...].jpg">

I already updated the Yoast SEO plugin to the newest version, but didn't solve the problem.

Anyone has any clue?

  • Questions regarding third-party products are outside the scope of this site - but it looks like FB just deletes that newline, so it probably needs to be a space. If you can't manually modify that yourself, you may need to hit up Yoast's official support channels. – bosco Sep 27 '17 at 0:15
2

The https change was not the cause. Actually - coincidentally - the W3 Total Cache was updated on the same day, and the Minify setting was breaking lines between meta and property words on the HTML, which were causing the error on Facebook debug tool.

| improve this answer | |
1

I don't think the tag is wrongly formatted because of the SSL certificate.

Sometimes, it takes quite a while (several hours?) for Facebook to update its cache. It's confused me before, too.

As a matter of fact, the tag in the source is what Facebook uses to generate its preview. So if that's correct, you should eventually be okay.

Think the Facebook developer pages should let you clear the cache for your page manually, too.

| improve this answer | |
  • But it used to work instantly. As soon as we published the posts and debugged, Facebook was taking the image correctly. Right after the https change it all messed up. – Adriano Castro Sep 19 '17 at 11:47
1

Use the facebook debug tool. You can use the "scrape again" button to make sure the featured image gets pulled back in.

https://developers.facebook.com/tools/debug/

| improve this answer | |
  • I tried that a lot of times... actually I'm trying for 2 days and nothing... it keeps saying: Inferred Property The 'og:url' property should be explicitly provided, even if a value can be inferred from other tags. – Adriano Castro Sep 19 '17 at 11:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.