Normally, I can filter product by attribute via calling "mysite.com/shop/?filter_brand=tesla"

However, when I tried to call it as "mysite.com/brand/tesla" but it doesn't work and show 404 not found.

I keep this setting by default. Permalink Setting

How can I call filter it as permalink i.e. "mysite.com/brand/tesla" ?



Go to Attributes > Brand, edit the attribute, then enable the archive (there is an option), and finally re-save permalinks.

If it 404s from then, ensure there is no page or other taxonomy called 'brand' because it will conflict. Test another attribute if unsure.


Product attribute permalink doesn't work #16825

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.