0

I have a problem when sharing a website on linkedin (it works well on facebook).

I use the theme "Foundry", and SEO by YOAST (free version).

I have the right OG informations in the head of my document, but when sharing the website on Linkedin, the page title showing is "Home Layout 5", which is the ADMIN name of the page and appears nowhere on the front-end page. It also picks up a random image, but SEO by yoast doesn't put the og image tag in the header, how can I change that ?

I never had this problem, what could I do to resolve it ? I searched and couldn't find anything.

Thanks for your help

0

Its not a theme or SEO by Yoast issue, Basically, It is a linkedin issue. Unfortunately LinkedIn caches the data it retrieves the first time the link is previewed and keeps it cached for a week!

The only way to clear the sharing preview cache for LinkedIn is to trick LinkedIn into thinking your page is a different (and new) page. This can be done by adding a parameter to the link. It doesn't affect your webpage, but it does force the metadata to be re-fetched for your website.

Example:

Original Web link: http://YOUR_WEBSITE_URL/My_Page 
"New" Web link: http://YOUR_WEBSITE_URL/My_Page?1

So we have just added ?1 . As a matter of fact, you can change the URL back to its original structure after the preview has loaded.

More Tips:

  • Update your "SEO By YOAST" Plugin to use latest version.
  • Update your "Foundry" Theme to use latest version.
  • Thanks, I tried that but it still won't change :/ the admin title is nowhere in the page so I can't understand how to solve this. – Matoma16 Sep 14 '17 at 8:31
  • Can you show me the url that you are sharing on linkedin? @Matoma16 – Asfandyar Khan Sep 14 '17 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.