0

I am using WP Migrate DB to migrate WordPress website built with Avada from local to a VM.

I am doing a find and replace with Find: //localhost/website and Replace: //10.60.8.118/website

Find: C:\xampp\htdocs\website and Replace: /var/www/html/website

All the links are fine but fontawesome, icomoon and fonts which are being loaded from Avada are showing an error in console. I don't understand why still I have localhost URLs. (When I search for the term localhost in database I get no results)

Access to Font at 'http://localhost/website/wp-content/themes/Avada/includes/lib/assets/fonts/fontawesome/fontawesome-webfont.woff2?v=4.7.0' from origin 'http://10.60.8.118' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'http://10.60.8.118' is therefore not allowed access.

and so on. Also I get an error "URL can't be found" when I go to inner pages. (Note that I have reset my permalink and also checked .htaccess file which is default from WordPress)

May I know what might be wrong?

closed as off-topic by Krzysiek Dróżdż, Jacob Peattie, bosco, Jack Johansson Sep 25 '18 at 4:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Jacob Peattie, bosco, Jack Johansson
If this question can be reworded to fit the rules in the help center, please edit the question.

0

This issue with your file path URL.
Still, Fontawesome trying to load fonts from "//localhost/website/wp-content/themes/Avada/includes/lib/assets/fonts/"

Change all of your file path URL with your new site URL.

  • yes. That's what my question is. Why am I still getting localhost URLs if I have already replaced all the URLs. – Kiran Dash Sep 12 '17 at 5:23
  • the issue was: Avada was creating styles in the uploads folder with URLs having localhost. – Kiran Dash Sep 20 '17 at 8:32
1

Avada > Theme Options > Advanced > Dynamic CSS & JS, and clear fusion cache.

Not the answer you're looking for? Browse other questions tagged or ask your own question.