0

I'm trying to apply a skin to a custom wp_editor(), but it does not seem to apply whatever I do.

The skin is generated from the TinyMCE LESS files, per instructions on https://www.tinymce.com/docs/advanced/creating-a-skin/

In my theme's folder I have a folder called /css/tinymce containing the following files:

content.inline.min.less

content.min.less

skin.min.less

This is how I'm calling wp_editor, with the skin_url setting for TinyMCE, but it does not seem to apply the skin.

$settings = array(
    'media_buttons' => false,
    'textarea_rows' => 1,
    'quicktags' => false,

    'tinymce' => array(
        'toolbar1' => 'bold,italic,undo,redo',
        'statusbar' => false,

        'resize' => 'both',

        'paste_as_text' => true,

        'skin_url' => get_template_directory_uri() .'/css/tinymce'
    )
);

echo wp_editor('', 'custom_editor, $settings);
1

Apparently, the default WordPress style files overwrite a custom TinyMCE skin. So what you need to do is deregister WordPress's TinyMCE skin.

Since I needed the custom skin to only apply on the front-end on my website, I wrapped it inside an !is_admin() conditional.

function remove_editor_buttons_style() {

    // If not on wp-admin
    if ( !is_admin() ) {
        wp_deregister_style( 'editor-buttons' );
    }

} add_action( 'wp_enqueue_scripts', 'remove_editor_buttons_style' );
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.