I want to restrict the width to a maximum of 600px for images uploaded using the "full size" image option in WP posts/pages section.

I've tried two methods:

Method 1:

Adding the following to style.css of the theme:

.post img {
max-width: 600px; /* Adjust this value according to your content area size*/
height: auto;


Method 2:

Adding the following to the top of functions.php:

$GLOBALS['content_width'] = 600;

Both of them are not working. The option for full-size is not available in Settings > Media

Please help.

2 Answers 2


Full size images are unmodified by default as it literally is the full size image. You could ensure the photo is a suitable size prior to uploading or restructure your theme so that full size images are not linked and are perhaps replaced by large images which can have their size set in WP Admin.


Fixed my problem usinng http://wordpress.org/extend/plugins/scissors-continued/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.