-1

i'd like to import a flash audio player in my wordpress theme, the import of the file works fine because it shows up on screen, responds to the click on play/pause, but the sound does not start.

edit : i found out the path has to be modified in the .as file, with the right path. Thanks sancho

All the files are in : /Applications/MAMP/htdocs/wordpress/wp-content/themes/maVersion/

and the mp3 are in : /Applications/MAMP/htdocs/wordpress/wp-content/themes/maVersion/audio

i'm in local, so i tried with the whole path (see the first line) or with a "normal" path (like the second line - i made 2 tests for both examples) :

<?xml version="1.0" encoding="utf-8"?>
<PLAYLIST>
<SONG URL="/Applications/MAMP/htdocs/wordpress/wp-content/themes/maVersion/audio/dance.mp3" TITLE="First Track - Dance" ARTIST="John Doe" />
<SONG URL="audio/audio.mp3" TITLE="Second Track" ARTIST="Random Singer"/>
<SONG URL="audio/dance.mp3" TITLE="Third Track" ARTIST="Super Generic Singer"/>
</PLAYLIST>

but still no sound.

Does anybody know what the solution is?

Thanks

Paul

1

You should be putting in the URL rather than a system path as the flash will requesting files via http.

Say your site is on http://localhost/wordpress/ ...

Your URLs need to look like http://localhost/wordpress/wp-content/themes/maVersion/audio/dance.mp3

  • Thanks sanchothefat! okay i found out i had to change the path in the .as file, i added the rest of the path from the http:// and it works. Thanks a lot ! Cheers man – Paul Sep 5 '11 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.