Issues with uploading my theme to localhost using WAMP Server on Windows 7 Home version.

I've changed the limit to 635mb in the php.ini. However, there seems to be TWO php.ini files. These are currently situated:
C:\wamp64\bin\php\php5.6.25 AND C:\wamp64\bin\php\php7.0.10.

So, I changed the limit on both php.ini files (as I had no idea which one was the correct one to copy across) to the size of the zipped theme folder being 635 MB (666,161,152 bytes), and copied them both (at separate stages and overwrote) into the folder C:\wamp64\www\lps\wp-admin where apparently they are to reside.

I'm trying to upload the theme http://localhost/lps/wp-admin/update.php?action=upload-theme... but to no avail. The theme is Uplift_v1.3.62.

I would be extremely grateful for some advice. BTW, I restarted WAMP Server each time I changed the files.

  • have you asked the theme's provider for help?
    – Michael
    Aug 15, 2017 at 0:08
  • 1
    First, I noticed that you mention wp-admin, did you mean wp-content? Since you should not change the content of wp-admin folder. Second, I would set the upload limit to a few megabytes more than the file size. 650,240KB and 650,241KB are both 635MB, but the former will be uploaded, while the latter won't. Also, you can simply extract your theme to wp-content/themes/ without having to upload them using theme manager.
    – Johansson
    Aug 15, 2017 at 0:11
  • Thanks @JackJohansson. I did perform most of these actions aside from the uploading manually into the w-content/themes which I have now done. Cheers
    – Fliss
    Aug 15, 2017 at 1:37

1 Answer 1


You should upload the theme manually to the server - copy the theme folder to your system folder corresponding to this URL:


After you're done copying the files, you will get the option to preview or activate the theme in the admin:


Also, make sure you copy only the theme source folder, and not the whole documentation, with PSDs and so on. If you're not confident that is the right folder, check to see if it contains style.css - that's a file that should be directly in the theme folder, not any subfolders.

  • 1
    I have to agree here. good advice. To be clear, the theme itself is likely NOT 600 megs.
    – rudtek
    Aug 15, 2017 at 1:23
  • @MihaiPapuc thank you very much.. Of course this was the logical thing to do but I was soo hooked on uploading by zip! I'm now installing and activating all the plugins. Thanks again. :-)
    – Fliss
    Aug 15, 2017 at 1:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.