0

I’ve had an automatic update to 4.8.1 (on local, staging and production-sites) on thursday the 3rd of August and since it is no longer possible to access the admin dashboard.

Admin bar in current state

In the header, i have the impression that i've lost administration capabilities although they are correctly configured in the database. As you can see, no additional menus are accessible from the admin-bar.

I’ve read through the thread for the 4.8 update and followed all hints (emptying browser cache, disabling plugins/themes (i get the white screen of death when doing so), troubleshooting in browser for JS errors, copying a fresh copy of WP, enabling troubleshooting in wp-config.php,…)

Also checked this link : https://blog.templatetoaster.com/wordpress-4-8-issues/ where they mention this issue, but not how to fix it unfortunately

I tried to add a new admin in phpMyAdmin but same outcome as above.

Is there something else I have forgotten ?

Many thanks for any additional hints !

4
  • Hi Le Conseil Informatique, Have you tried to check if your database access is working ? Maybe you just have a problem with your SQL server ? What is your server configuration ? Paul Aug 11, 2017 at 15:51
  • If you get the white screen of death it means that you have a php error somewhere. It might or might not be related to your problem, but you should look into your error log and try to fix it first Aug 11, 2017 at 15:58
  • Hi @PaulHunault Accessing DB is functional on all instances. Server config's as follows : Dev : MySQL 5.6.17/ PHP 7.0.3, Staging : MariaDB 10.1.26/ PHP 5.6.30 & Prod : MySQL 5.5.57/ PHP 7.0 Aug 16, 2017 at 8:18
  • Hi @MarkKaplun, checked error logs but there are only 2 errors for plugins, one concerning WP Jobmanager, the other BrokenLinkChecker. Disabling these does not change anything unfortunately. Aug 16, 2017 at 8:22

3 Answers 3

0

As mentioned in the comments, the first place to look is the error log. That will usually point you to an error in a plugin.

You can disable an individual plugin by renaming it's folder. You can quickly disable all plugins by renaming the plugins folder. If you rename the entire plugin folder, then create a new plugins folder, and move individual plugin's folders into the new folder, thereby enabling them. The 'bad' plugin will cause the error to reoccur.

It is possible that a theme is causing the problem. Use the same technique to quickly disable your theme...that will cause WP to use the default theme.

4
  • Hi @RickHellewell. Followed you're instructions but nothing does it. When switching to default theme, white page of death occurs (see comment above @MarkKaplun). When switching back to default on my dev server, I've now even partially lost CSS of my child theme :( Aug 16, 2017 at 8:25
  • Let me add to this that I have several websites using the same theme (Avada) and who updated themselves to 4.8.1 and none of theme present the same malfunctions. Aug 16, 2017 at 9:02
  • Do you see anything in the error log when you get the "WSOD"? Have you tried WP_DEBUG = true in the wp-config.php file and then look at the error log? If other sites are using the same theme, then perhaps the problem site has different plugins enabled? Aug 16, 2017 at 17:55
  • Nothing more then stated in comment to Mark Kaplun above. I have found a solution in meantime though. Please see answer. Aug 17, 2017 at 8:44
0

I did not find any technical answer to my problem but what I did was to roll back to a backup of my database (which means I'll have to rewrite some of the stuff I've lost, but it'll save me time in the end I think)

The WP version is 4.8.1, theme is functional, all extensions are enabled and everything works on dev server, go figure.

0

I had exactly the same symptoms, but not in the exact same circumstances. I my case it was a migration (same website URL, but different host). Here is how it happened and got fixed so that hopefully it is useful to someone else.

In the process of the migration, I wanted to change the database prefix from wp_ to newprefix_. So I changed wp-config.php accordingly, and before injecting the database, I opened the .sql file that was exported from the previous host, and changed all occurrences of `wp_ to `newprefix_. Turns out some stuff shouldn't have to be replaced like that, because that's when, like you, I could log in, but not access Wordpress' admin pages.

I could regain access to them when I restored wp-config.php and the original database.

As for changing the prefix, I did it afterward with the fine iThemes Security plugin (this feature is a bit hidden. You have to go to Admin page > Security > Settings > Advanced > Change Database Table Prefix).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.