0

I'm using ACF to build some custom elements on pages and also WPML to manage the translations of these pages.

I am currently seeing an issue where the pages do not save when I update the language content.

In the WPML custom field settings I have each custom field down to the Translate option.

Within each page I am copying the content to a language to pre-populate the custom fields and not use the synchronise option as I want to translate this independently.

Any ideas as to why my content is not saving and reverting back to the original?

Thanks

closed as off-topic by Jack Johansson, Howdy_McGee Aug 18 '17 at 4:02

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • do you have a lot of fields, or repeater fields? – rudtek Aug 7 '17 at 19:41
  • There are quite a few fields yes, some of which are repeater fields. – Shane Jones Aug 7 '17 at 19:49
1

I've had a fair share of issues with ACF, but end up using it still.

There could be 3 things causing your problem.

you could try changing your php settings:

max_input_time = 42000
max_execution_time = 42000
max_input_vars = 50000

This next one is not a great fix as if WordPress ever decides to update their tables it could cause problems (but that hasn't happened yet):

wp_options table, option_name column -> increase length from 64 to something else, like 255

More painfully you need to shorten your field names. If you're using something like my_super_cool_extra_amazing_language_field, acf starts taking a lot memory. Shorten all field names.

This is all of course assuming you're not using any special functions to save the field as i wouldn't be able to test those with out seeing them.

  • Most often increasing max_input_vars does it for me -> those setting are added to a php.ini file. – gdaniel Aug 7 '17 at 20:02
0

Tried a number of solutions including the ones on this post.

Turns out the the site already once had WMPL installed and the database tables were still in the database even after the plugin had been uninstalled. Some hangover values in there were causing the issues.

The solution for me was to got into WPML > Support > troubleshooting > Reset PRO translation configuration, select the check check-box "I am about to reset the project settings." and click to the button "Reset all languages data and deactivate WPML".

When I did this and went through the install script everything worked fine and as expected.

Not the answer you're looking for? Browse other questions tagged or ask your own question.