1

I embedded a Mailchimp newsletter registration using the mailchimp-plugin, which works just fine for logged in users and also on other websites of mine. But on this page, users who are not logged in, can't click the submit button hof the form. It just has no effect and no error message appears. Nothing is happening.

EDIT: Could the problem be the fact, that there are two forms on the page, when the user isn't logged in and mailchimp can't figure out which input field are the right ones?! The weird thing is, that it works fine, if I use the option "convert text inputs to textarea", of the browser plugin 'web developer'!

Here is my form:

    <form class="snp-subscribeform snp_subscribeform layout_form cr_form cr_font" method="post">
  <script type="text/javascript">
    (function() {
      if (!window.mc4wp) {
        window.mc4wp = {
          listeners: [],
          forms: {
            on: function(event, callback) {
              window.mc4wp.listeners.push({
                event: event,
                callback: callback
              });
            }
          }
        }
      }
    })();
  </script>
  <div class="mc4wp-form-fields">
    <div rel="text" class="cr_ipe_item ui-sortable musthave footer-newsletter_firstname"> <input type="text" name="FNAME" placeholder="Firstname*" required=""></div>
    <div rel="text" class="cr_ipe_item ui-sortable musthave footer-newsletter_lastname"> <input type="text" name="LNAME" placeholder="Lastname*" required=""></div>
    <div rel="email" class="cr_ipe_item ui-sortable musthave footer-newsletter_email"> <input type="email" name="EMAIL" placeholder="E-Mail*" required=""></div><input type="hidden" name="INTERESTS[57aa0ce9f6]" value="ccbb36e6a3">
    <div rel="button" class="bld-el-cont bld-el-button cr_ipe_item ui-sortable submit_container"> <input type="submit" class="bld-el cr_button" value="Register" name="mc_newsletter_submit"></div>
    <div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"></div><input type="hidden" name="_mc4wp_timestamp" value="1502116875"><input type="hidden" name="_mc4wp_form_id" value="7342"><input type="hidden" name="_mc4wp_form_element_id"
      value="mc4wp-form-1"></div>
  <div class="mc4wp-response"></div>

List of involved plugins:

  • hide my wp (premium)
  • All In One WP Security
  • buddypress
  • Contact Form 7
  • iThemes Security
  • MailChimp für WordPress
  • Plugin Organizer
  • W3 Total Cache
  • WP-SpamShield
  • WP-Sweep

I guess some of these plugins is blocking a script, redirect or something. I renamed/deactivated already the Plugins All In One WP Security, iThemes Security, W3 Total Cache, WP-SpamShield, WP-Sweep, and hide my wp, but nothing changed. I would be appreciated for your help!

1

Problem solved. There was a conflict with the Ninja Popups Plugin because it tries to capture any form submit.

The Contributer of the Mailchimp for Wordpress Plugin helped me here: https://wordpress.org/support/topic/buddypress-and-mailchimp-form-doesnt-work-together/#post-9397642

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.