0

Even though I type "http://aoafinc.org/wp-admin" into the address bar, it was turned into "https://aoafinc.org/wp-admin". Also, all the links to images on my site are "https" instead of "http". Since my SSL certificate has expired, all these images can't be loaded.

I just take over this website from someone and don't want to renew the SSL, also I am not very familiar with WP or SSL either, but I guess I don't have to manually edit all the image links, there should be somewhere on WP's back end to set the website as non-ssl and hopefully all links will become "http". And more essentially, why the browser is requesting HTTPS url even though I type in a HTTP url?

0

I think you should just get the certificate renewed, and if you need a free one go to letsencrypt.com. A growing number of hosts offer Lets Encrypt certificates as an "easy click" type option on their control panel too.

If you're real keen on taking down the TLS/SSL functionality, I hope you'll at least mention that to your client before removing a good part of their websites security all on your own.

0
  • Check your .htaccess file and remove the https. e.g:

    RewriteEngine On
    RewriteCond %{SERVER_PORT} 80 
    RewriteRule ^(.*)$ https://url.com
    

  • Check the wp-config.php file and remove define('FORCE_SSL_ADMIN', true); if exists

  • Also, you can change the URL from WordPress backend: General Settings -> General

  • Lastly, If you can't access the wp-admin then you should check the WordPress table options. There are two options you have to change:

    1. siteurl
    2. home

Make sure these two options have http url not https.

  • I did. And I just found out with "multi_site" setting on, there is no siteurl and home in the setting page. Without knowing how to turn it off from backend, I just edit wp-config.php file. Now I have changed these settings to HTTP link. – shenkwen Aug 4 '17 at 3:23
  • The siteurl and home options you can change it from the database. – Syed Fakhar Abbas Aug 4 '17 at 3:27
  • and if you don't want to use multi site option then check this link wpbeginner.com/wp-tutorials/… – Syed Fakhar Abbas Aug 4 '17 at 3:37
0

For multisite, you can only change this in the database. Go to your database, and look for table:

_options

Then look for rows

siteurl

home

And change https to http.

Then look for table

_sitemeta

and look for row siteurl and change the https to http

I would do a database backup before editing your database.

If it's still showing https after this, you might need to clear the browser cache, for chrome go to settings > clear browsing data > tick 'browsing history, cached images and files' and clear the history.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.