1

I am having a problem when creating scheduled posts. I create the posts as normal, click edit, set a scheduled time and click ok then the shedual button. Soon as i do this i check the website and the post has been published immediately. I looked back in the view all posts page and the post says its still scheduled. It was working fine for months but suddenly this is occurring. Really need this sorting asap! cheers

  • You can view scheduled posts as if they were public if you're logged in, but they won't appear in archives. Where are you seeing the published post? On the main blog page? – Jacob Peattie Jul 25 '17 at 12:47
  • The site is just one page. So i think it must be. Not sure if its anything to do with being logged in. I can view the site from another computer and the post is still published. – TomPo101 Jul 25 '17 at 13:02
  • Try installing a plugin called WP-Crontrol which basically will help you debug WP-Cron and add more details to your question. – user170297 Jul 25 '17 at 13:07
  • I installed it and i can see the cron event for the scheduled post. The date is correct and the post still says its scheduled on the posts page. But the post is still viewable on the website. – TomPo101 Jul 25 '17 at 14:09
0

I'd check to make sure that the scheduled time is actually in the future - date and time. And check the time offset settings on your site are set to the proper time zone.

  • I set the date to a month from the current time. I have already tried changing my time zone from UTC + 0 to London where i live. It was working on UTC+0 and just suddenly stopped. I haven't changed anything recently apart from install the zoast seo plugin and a minify plugin. Surley they cant be connected to this? – TomPo101 Jul 25 '17 at 18:07
  • It also does it on my local host as well. Really strange this. – TomPo101 Jul 26 '17 at 14:51
0

Ok i managed to fix it. I added 'post_status' => 'publish' to my WP-Query args in the loop and it seems to have solved it. Really bizarre that its been working for months without this argument. Wonder if one of you clever people has a clue to whats happening? cos im baffled!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.