1

Every few days my WP automatically marks "Automatically close comments on articles older than 28 days"

I don't want this! I want to keep my comments open forever. How can I stop WP from marking this option every 4 days?! I don't know why it's doing this.

Thank you so much!

closed as off-topic by Michael, Jack Johansson, kraftner, cjbj, Rarst Jul 26 '17 at 12:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions that are too localized (such as syntax errors, code with restricted access, hacked sites, hosting or support issues) are not in scope. See how do I ask a good question?" – Michael, Jack Johansson, kraftner, cjbj, Rarst
If this question can be reworded to fit the rules in the help center, please edit the question.

  • WP most certainly doesn’t automatically change this (or any other) native option by itself. Something that is not WP core is doing that. Unfortunately hard to guess why. You might try inquiring with your hosting support if they run anything special for WP, review plugins you use, and so on. – Rarst Jul 26 '17 at 12:27
3

You can change the preference from settings.

Navigate to Settings > Discussion page on your wp-admin

Find Automatically close comments on articles older than and uncheck that option.

Screenshot

That should solve your problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.