0

ACF values are only showing in the front page, regardless of my Location settings rules clearly stating that these values can show in "Post Type" = "Post".

enter image description here

I read about the get_option('page_for_posts') parameter but didn't work for me. Should the option string reflect the page template you are trying to read? Cause I changed it to "home" and "front-page", but didn't work either.

Someone knows what can I do to have the values show in my single post template?

Thanks.

2
  • Are you using any other plugins that may be altering the normal editing screen? One thing to try is to go to a post editing screen and use the "screen options" tab at the top right. Maybe the ACF box is unchecked, and checking it will make it appear? In either case the ACF fields will only appear on the back end - in the editing window - and not on the front end, the user-facing side of your site. You'll use functions like get_option() in your theme to display them on the front end. They can't and won't display on the front end, to visitors, without manually setting that up.
    – WebElaine
    Jul 20, 2017 at 21:54
  • I had a few things wrong that I fixed by using Query Monitor and understanding I was pointing to an incorrect template file. But yes, I made it work with get_option() and using the correct page as parameter.
    – MauF
    Jul 21, 2017 at 14:22

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.