1

I am facing a strange issue of WordPress taking 100+ seconds to load in backend as well as front end. My website is nawkaar9.com hosted on Digital Ocean 512 MB Ubuntu VM. I read a tons of answers and I have tried the following solutions:

  1. Disable Plugins - I disabled all of them at once and still the issue persists .
  2. Switch to default theme - I switched to twenty thirteen but no results.
  3. P3 Profiler plugin - Actually there was no point in installing this plugin as the issue persisted even after disabling ALL plugins but still I installed this plugin and checked the stats. I enabled a few basic plugins from site to get some stats. Check the attached screenshot. Strange thing is it shows everything as normal. 0.3 sec as load time P3 Profile Plugin wise info
  4. Used Query Monitor - It shows 100 + seconds it takes to load. Shows some warnings and notice but no errors as such. enter image description here

  5. Updated WordPress from 4.6 to 4.8 - Still Issue persists

  6. Rebooted Droplet - same here
  7. Restarted Services - Apache & MySQL
  8. Doubled RAM limit for WP in wp-config from 128 to 256

    1. Checked HardDisk space - 50% is free
    2. Swap of 1GB already exists and most of it is free
    3. Asked Digital Ocean support - they say everything is fine from there side, the issue is with plugin or theme
    4. Set wp-debug to true but there are no errors
    5. Created New HtAccess file through permalinks settings

    Some say upgrade your VM to 1GB plan. But honestly it was working fine till date as traffic on website is low and also used free -m to be sure.

Please let me know if I am still missing anything or suggest something that I can try out.

Thanks in Advance

  • sorry, but it is impossible to just guess. most likely your server is just too weak or you have some misconfiguration on the mysql level. – Mark Kaplun Jul 19 '17 at 19:22
  • 1
    ... and based on the last warning, you might have a malware, or you are trying to conect to non responsive external server – Mark Kaplun Jul 19 '17 at 19:24
  • have you tried loading the page with the network tab in the inspector open? do that and see if you have any specific files or requests taking a super long time to load – mrben522 Jul 19 '17 at 20:12
1

You should not ignore those warnings. From screenshot, It shows your theme is using deprecated mysql functions. Check your apache2 logs -> If this is really an issue there will ton of logging If yes, your theme is causing the issue.

If the above is true, do this:

1) Switch to some other theme.

2) Remove the parent theme code. (instead of just disabling it)

3)Upload the latest version of theme.(I am Assuming the update for that theme is available)

Let me know if that works.

0

If you're not already doing so, you can run a plugin like WP Super Cache which will create static HTML pages of most things to serve them up to users. I recommend this one specifically because it is maintained by Automattic.

Another plugin you can use is one like WP-Optimize which will clean up things in your database like removing auto-draft/trashed posts, etc.

Other than that, you're probably going to have to contact your hosting provider's support team and take this up with them.

  • Yes, I cleaned up using WP-Optimize as well. I had also installed W3 Total Cache in past but it only reduced speed for some reasons so had disabled it few months back. – Ankit Shah Jul 20 '17 at 6:17
0

Check your PHP Memory Limit and your PHP Post Max Size on your php.ini, also update your php version to 7 onwards.

  • Hi Nuno, thanks for your input. However my staging site on the subdomain works perfectly. The issue seems to be site specific. – Ankit Shah Jul 20 '17 at 13:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.