0

I'm trying to set a contact form on my site but have a little problem with the auto responder (use mail 2) the From field.

I'm testing it by myself so i act like an admin and a user on two different emils.

When the filed is set to: [your name] <[your-email]> it throws an error:

Sender email address does not belong to the site domain

That's ok. But even when set to: myMail@myDomain.com it goes to the sender junk mail.

So how can i set it please?

Thank you in advance.

0

The issue you are having is because you are using the users name and email address from the contact form submission when you should be using your own website domain email address as the error states. If you do not not have any emails set up on the domain, I would recommend you use a noreply@

I usually set my Mail 2 From Email to be:

Website Name or Company Name <noreply@your-domain.co.uk>
  • When i set it to noreply@your-domain.com it goes to junk mail – shireef khatab Jul 17 '17 at 21:14
  • I would assume this is to with your server settings, it may be worth speaking to your hosting provider or maybe look at using SMTP instead of the default PHP mail function. wordpress.org/extend/plugins/wp-mail-smtp – heady12 Jul 18 '17 at 7:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.