1

This is my website https://thequintessentialmind.com/

After installing ssl certificate images won't show or show as missing.

I have updated almost all the urls to https but the problem insists.

Any ideas?

1

I suppose you have Adaptive Images plugin installed?

The author suggests for now:

Can you check if the urls in your admin Settings > General page do contain the “https” instead of “http”? They should contain the “https” and (sorry about this inconvenience) you need to update your Adaptive Images settings one more time after this.

Also, for a proper and complete migration from HTTP to HTTPS, I would advice performing a url rewrite in your database, which will replace each and every url of your domain from “http” to “https”.

But this is a fresh problem so there's a possibility that this solution will not work 100%, so I recommend to watch that thread. You can also disable this plugin until this problem is fixed by the author and maybe that will solve your problem for now.

2
  • Thank you! How did you find out which plugin was causing the issue? – Andrilio Jul 14 '17 at 21:29
  • I googled the error message Original image not found or not available.. :) – Picard Jul 15 '17 at 19:10
0

That is due to the fact that the images were uploaded in a non-ssl environment. Thus, in the database, that is the reference. If you look at the URL in the media library, you will see that they are a http:// and not https://

There is a plugin that fixes the problem, Really Simple SSL by Rogier Lankhorst
Delete the image files and re-upload with a slightly different image name.

I have done both methods, depending on the development state of the site.

1
  • I tried to delete and re-upload the image but still, the image won't show. – Mimi Jabonga Apr 10 '19 at 18:05
0

Changing it in the wp-config.php helped me, so now I can see images after changing to https.

1
  • yes, but I want a floating plugin that you don't have to modify the core WP files – Debbie Kurth Apr 19 '19 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.