2

I'm having a little odd problem where by when I upload an image I have optimized down to say 200kb, when its displayed on the site WordPress has actually increased the file size to 800kb.

My original 200kb file is shown in the media library but when using the full size version in a post it is the 800kb file that WordPress generated.

In the post the image has a file extension like this my-file-2592x1197.jpg which is the 800kb one. In the library it is just my-file.jpg which is the original 200kb file I uploaded of the same dimensions.

Ideas? I'm not sure if this is a WordPress or theme problem.

  • Did you change/set the compression when you originally saved the file? Could be that this happens due to different quality (see this thread, where something similar happened) – kero Jul 13 '17 at 14:42
  • Yes I did set the compression when saved out of Photoshop. The 200kb files are on my desktop which I uploaded. – caffeinehigh Jul 13 '17 at 14:47
  • Then you could try changing the default jpeg compression quality as described here (but beware, this will chnage the quality for all uploaded images) – kero Jul 13 '17 at 14:51
1

OK I seem to have found the answer to this. The theme I'm using has Aqua Resizer installed. Quality was set to 100% which for some reason made the resized versions bigger in file size. I've changed the quality setting to 80 and it has sorted it.

1

Just for future reference, to change the quality of uploaded images, there is a filter called . You can set the quality in the following way:

add_filter('jpeg_quality', 'change_jpg_quality');
function change_jpg_quality ($arg) {
    // Values below 70 and over 90 are not recommended
    return 85; 
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.